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Started
Getting

Once logged into your Echo Yearbook Pro account and you have selected your current yearbook 
project, you will see three large buttons: Upload Photos, View Deadlines and Design Pages. These 
are the main tools used to create your yearbook and provide quick access to these core features.

Manage
The Manage Tab allows you to edit your account information, setup your staff and their permissions, 
access your yearbook ladder and any content that has been uploaded. 

Upload
The Upload Tab provides quick access to upload photos and other upload features, such as uploading 
PDFs and videos.

Design
The Design Tab gives you design access to the different parts of your yearbook such as the index and 
general pages, as well as your People Pages. You can also request a Design Review from this menu.

Collaborate
The Collaborate Tab allows you access to Explore, Share, Discuss and Learn. These sections include the 
Template Library and Certification tests.

Request
The Request Tab gives you the option to request a Proof Book.

help
The Help Tab gives you access to additional online tools.
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Team
Manage your

The Manage Staff page is where you can add each member of your team by creating new login information, 
or invite staff members from previous projects to keep the same login information they already use.

Create your new team 
member logins here!

The 3 Staff Member Types: 
1. Admin:
Recommended for the primary 
contact and those who need full 
design and account/invoice access. 

2. Editor:
Recommended for students and 
those who require access to the 
Designer and Collaborate Tab. 
 

3. User:
Recommended for those who need 
only limited access to the website, 
such as Manage and Upload Photos. 

These types can be customized via the 
Manage Permissions page.
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Manage Photos
UPLOAD AND

Organize Your Photos
Utilize the Manage Photos page to organize your library of photos before or as you 
upload. This page is integrated with Instagram, Facebook, Google Drive, Dropbox and 
email submission.

To begin, create your photo categories by clicking 
on the Upload New Photos button, then Create 
Photo Category. You can also designate an existing 
category as a Parent category when creating a new 
category to make a folder within a folder. 

Once your category is selected, click on the Upload 
New Photo button. To upload photos from your files, 
click Browse and navigate to the photo file(s) on 
your computer.

Each category that you create will be automatically 
assigned an email address. The list of addresses 
can be found in the Email Photos button.  
Provide parents, teachers and other members of 
the school community with the corresponding 
email address(es). Any attached or embedded 
photos will automatically upload to that specific 
category once the email is sent.
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Upload PDFs to Website
 If you have any PDF files you need to upload to the project, you can do so in the  
 Mange Uploads section.  

Click the Upload File button. 
You can then select any 
page design PDFs you 
have created outside of 
the program. Designate 
the content type and any 
appropriate comments, then 
click Upload File button to 
complete the process. 

You can view any PDFs that have been previously uploaded to 
the account here. 

Manage Photos
UPLOAD AND
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TabDesign

The Design Tab gives you design access to the different parts of your yearbook such as the index, general 
pages and People Pages. You can also request a Design Review from this menu. 

Page Design:
Choose a page to design from the ladder preview on the left side of the screen. You can then use the 
tools to design your pages. 

Design People Pages:
In this section you can create student portrait pages in three steps. 
1.  Student portraits and data will be uploaded to your 
 account by Inter-State Studio. If you are an 
 Inter-State Studio photography customer we will 
 seamlessly upload your images and data. If you are 
 not a photography customer we will need you to 
 send us your PSPA CD to upload this information 
 for you. 
2.  Select students by class, grade or teacher. Then, 
 choose a template. 
3.  Automatically flow all of your student portraits onto 
 specified yearbook pages. 
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LadderYearbook

Planning Your Yearbook Pages
View your yearbook progress, assign pages to staff, designate page content and directly access pages 
to design.  

Page
Numbering:
Add page numbers to 
your yearbook pages. 
Simple and advanced 
options are available. 

Spell Check Box:
Review potential 
spelling errors page-
by-page. This feature 
will make approved 
corrections to your 
page(s) automatically. 

Submit for
Production:  
When you are ready to 
submit your book for 
production, this button 
will take you to the 
approval form. 
 

Preview 
Yearbook: 
View the digital 
flipbook of your 
yearbook progress. 
You can also generate 
a PDF version of your 
book sent to an email 
address of 
your choice.  

Please Note: Your yearbook cover will be created in a separate program from Echo Yearbook Pro. You 
will receive an email with login information to Cover Design Studio. This software will allow you to select 
from any of our 30+ standard covers and allow you to upload your custom cover.  

In these boxes you can assign 
pages to members on your 
team. You can also lock certain 
pages once they are complete 
to prevent further editing from 
non-admin staff members. 

You can access your designer by clicking on the Design Page button 
next to the corresponding page you would like to access. 
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Designer
ACCESSING THE 

When in Echo Yearbook Pro: 
Access the designer using the Design Tab or Manage Ladder. Only one person can access a spread at 
one time. It is recommended to use Google Chrome or Mozilla Firefox as your browser while you design 
your pages.  

Click the gray X to hide the Select Page side menu for pages and return to the left toolbar.  
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DesignerIn the

Welcome to the designer!  
 On the left side of the page is the Select Page menu. Select a spread to open   
 the pages and begin your design.

Click the red X button at the top right of your page in order to close the 
designer and return to your ladder. 

Page Guides
While in the designer, these colored lines on the canvas will guide the placement of your content:

Red Guideline
This is the bleed line. All 
backgrounds should 
meet or exceed this 
line completely to 
ensure a clean bleed 
off the page.  

Black Guideline
This is the trim line, 
where the pages 
will be cut during 
production. This 
designates the 
actual page edge in 
the final product.  

Black Center Line 
This is the center of 
your spread, where 
the pages will be 
bound to the cover. 
Make sure text or faces 
in pictures are not in 
this area.   
 

Purple Guideline
This is your margin or 
“safe zone”. 
Any items you do not 
want to get cut off 
must stay within the 
purple guidelines.  
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Toolbarsdesigner

Top and Left Toolbars:

Save
Click this button to 
save your changes.

Copy 
Frame

Fill
Color

Border
Width

Lock
Frame

RotateUndo

Paste 
Frame

Redo Border
Color

Delete
Frame

Move to
Front/
Back

Insert Photo

Insert QR Code

Insert TemplateInsert Text

Insert BackgroundInsert Shape

Insert Approved AdsInsert PDF

Insert Clip Art

Mange People Pages

Edit Background ModePreview Mode

Auto GridPage Builder

Recover PagesMove Pages
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Tabsdesigner

View Tab
In the View Tab, check the box next to the feature you 
would like to activate. With the Ruler, measure the 
dimensions in inches and distance of objects to the page 
edge. The Snap To feature will display a green line when 
an object aligns with the edge of another object while 
being moved. The Grid feature will overlay a transparent 
graph onto your page.  

Page Tab
The Page Tab offers the options to mirror a page layout or 
clear a page when you want to start over from scratch. 

Frame Tab 
The Frame Tab provides quick access to frame settings 
such as add drop shadows to an object, add rounded 
corners to a selected object, or apply wrap text to an 
image so that text wraps around its edges. 

Automate Tab 
In the Automate Tab, you can manage your people pages. 
You can also access the index generator.  

Settings Tab 
In the Settings Tab you can manage page locks that are 
created by your staff members. This is useful when a staff 
member does not properly close a spread. Deleting the 
page lock will allow other members to access the spread. 

Help Tab 
The Help Tab is another way to access support 
documents. For additional help from our technical support 
staff please contact us at 1-888-823-6957.
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To Pages
Add Photos

Place Photos: 
 Access the designer using the Design Tab or Manage Ladder. Only   
 one person can access a spread at one time. It is recommended to 
 use Google Chrome or Mozilla Firefox as your browser while you 
 design your pages.

If you have inserted a template, there 
will be Drop Photo boxes. After you 
select a photo, click inside a Drop Photo 
box and it will appear.  

If a placed photo does not fit properly, 
you can adjust it by using the Photo 
Settings Tab on the right hand side of 
the designer.

After you select 
the photo, click 
anywhere on the 
page canvas and it 
will appear.
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To Pages
Add Photos

Drop Photo Boxes: 
You can insert these placeholder boxes as well.  

 
These are useful at the beginning of your project 
if you want to design a page without having 
photos available for that page.

Add a PDF:
Once you upload a PDF under Manage Uploads, you can place it on the page by 
clicking the Insert PDF button on the left toolbar.
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PhotosClip

When a photo is selected on the page, a Photo Edit Toolbar will appear under the top 
toolbar. In this toolbar, select Clip to remove the background from an image.

Foreground
Brush

Background
Brush

Scalpel Zoom
Out

Save 
Edits

Erase
Marks

Zoom
In

Zoom
to Fit

Mark as Done
and Exit

Clipping Editor

Use Foreground Brush for everything you want to keep in the photo. 
Use the Background Brush for anything you want to get rid of on the photo.

You are given 500 clipping credits at the start of your project. Each time you click Done you 
spend a point, so please use the clipping feature wisely. If you run out of clipping credits, or do 
not seem to have any, please contact tech support. 
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Text
Add

Place Text:
Select the Insert Text button in the Insert Items section of the left 
toolbar. Click on a default style and click onto the page to insert the 
text box. 

Once the text is placed on the spread and the text 
box is selected a Text Editing Toolbar will appear 
under the top toolbar. See more details on the 
next page. 

You can also Save as 
New Text Style so that 
you can re-use your text 
settings later without the 
need to reformat your 
text each time you place 
a new text box. 
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Text
Edit

Once the text is placed on the spread, and the text box is selected, a Text Editing 
Toolbar will appear under the top toolbar. 

Choose from our selection of various fonts and styles that will fit your yearbook page or 
theme. “Busy” fonts, such as Boogie Nights, are recommended for headlines only. 

Select
Font

Font
Size

Text
Alignment

Text
Edit Mode

Bold

Italicize

Underline
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Clip Art
Add Backgrounds &

To add backgrounds, click the Insert Background button on the left 
toolbar. Select a category or search for a specific background type 
using the keyword search button. Click on the desired background 
and click onto the page to insert it. Some backgrounds are intended 
for placement on one page and others will cover an entire spread. 

In order to edit the background you must be in Background Layer mode, found in the Actions 
section on the left toolbar. In this mode, you will be able to select or edit your background layer. 

Add Clip Art to add to the 
theme of your page. There 
are plenty of themes and 
categories to choose from to 
fit your idea. Use the keyword 
search bar or browse through 
the categories. 
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Template
Insert

Choose from a multitude of templates we have to offer under our 
Template section. These pre-designed pages can give you a great 
starting point to build from and save valuable time.

If there is content on the page when you insert a template, you 
will be prompted to replace or cover that existing content.

You have the ability to save your own pages as templates for later 
use. To Save as a Template, select the green down arrow next to 
the Save button. 

You will have the option to 
save just a single page or 
the spread. Custom saved 
templates are not visible to 
other accounts but can be 
accessed by your staff in the 
Templates button > Custom 
Templates category. 
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Recover Pages
Move Pages &

If you need to rearrange your pages, you can do so under the Move 
Pages button in the actions section of the left toolbar. 

The pop-up window that 
appears will allow you to click 
and drag spreads into a 
new order.  

Click Commit Page Moves to 
save the changes or use Reset 
Page Moves to start over.

If you would like to move single 
pages at a time, click the 
Advanced Page Moves button 
at the bottom right of the move 
pages pop-up window. 
You may bump some pages 
into the unused page dock at 
the bottom of the screen. In 
order to save your changes, 
the dock at the bottom of the 
screen must be empty. You can 
drag-and-drop important pages 
back into the correct place in 
your book, or delete the blank or 
unneeded pages.

You can choose between the 
last ten saves of a spread.

Recover Pages:
If you want to revert to a previous version of a spread, click on 
Recover Pages in the Actions section of the left toolbar. 
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Use Page Builder to place multiple 
photos in a template of your choice 
onto a blank page. Find this feature 
in the Action section of the 
left toolbar.

Once you click on the Page 
Builder icon a side menu 
will appear.

Builder
Page

This time-saving tool works in 
three quick steps: 

Step 1: Add Photos
Click on the Select New Photos 
button and your categories list 
will open. Choose the photos you 
want on the page. The selected 
photos will have a green border. 
Then click Add Selected Photos 
when you are finished with 
your selection.

Step 2: Add Photos
Click Choose Template to 
browse for your desired 
template. You may sort by 
category or by photo count, 
which will display templates that 
have the same quantity of photo 
spots available as selected in 
step one. Click Use Selected 
Template when your final 
choice is highlighted green. 
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Step 3: Create Page 
Click Create Page to view the generated template that Page Builder creates. You have the option to 
click Regenerate Preview so the photos shuffle around on your template or place the design on the left 
page or the right page once you are satisfied with the layout. 

Once the template is placed on the page, you can adjust the photo within the photo frames 
using the Photo Settings Tab on the right side of the designer. See next page for details. 

Builder
Page
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Menu
Advanced

The Advanced Menu Tab gives you more options to adjust and edit objects on the page. Click 
one of the tabs on the right side of the designer to expand those options. You must have a 
photo or text box selected to view the options within those tabs. 

To easily close any of the Advanced Setting tables, click the Advanced Menu button on 
the bottom of the designer. 

Photo Settings
Clear Image
Deletes the image, leaving the selected 
frame available for a new image.

Flip 
Horizontally or vertically flip the image. 

Fit
Gives several fitting options for the image.  
Use Manual to move image within the 
frame without altering the frame size 
or shape. 

The settings below the image preview 
allow you to change the image’s position 
on the page, dimensions, rotation and size 
within the frame.
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Settings
Text

In addition to Font, 
Size and Color options, 
this feature provides 
Baseline, Case, Tracking, 
Kerning and Leading 
for more advanced 
text formatting.

This tab is most 
frequently used to add 
or lower the opacity 
of an image so that it 
appears lighter than 
usual. The lower the 
percentage, the more 
transparent the image 
will become.  

Frame Settings 
Various border, color and fill options can be found here. The Inset options customize the margins 
between the text and frame.  
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For additional support in using Echo Yearbook Pro please contact
Inter-State Studio’s tech support at 

1-888-823-6957 
Or 

by email: techsupport@inter-state.com


